@jpyron Have you installed an SSL certificate? Or changed something in the DB config? Because in the screenshot you posted it looks like a broken link to the image.

Have you installed any new plugin(s) that deal with images?

If not, try to go to /wp-admin/options-media.php and check that the upload path is correct, and save the settings, and try uploading again.

 

Hope it helps!

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄