cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
New

Wordpress uploads has gotten VERY slow

It usually happens when I am uploading an image or doing something like setting a feature image, but also occurs when I might be editing something and go to save it. It seems like uploading to the server is triggering MASSIVE lag time. It might take 4 minutes to upload and then give me an error and I have to do it again -- that time it might happen faster. There doesn't seem to be much pattern.

 

I was trying to upload a batch of images (1000 photos or so) yesterday, which is when the problem started. I gave up and deleted them as they wouldn't import correctly with the 'Add From Server" plugin.

 

What's wrong? Has my upload speed been capped because of that failed upload?

 

Any help would be much appreciated.

2 ACCEPTED SOLUTIONS

@ioet 

 

Given the number of images you are trying to upload I would put memory to 256MB and put the max_execution_time to 300 - right now it's at 30 which is seconds

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

@ioet 

 

When you are in PHPMyAdmin you can select all the tables in the database - and then select optimize, you can also look at to see the size of each table in the database

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

17 REPLIES 17
Super User IV

@ioet 

 

What platform are you on? Managed WordPress, VPS, cPanel??

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Linux cPanel deluxe version

I also forgot to mention that I tried deactivating all plugins and
reactivating one by one, but it doesn’t seem to help


--

Sent from iPhone

@ioet 

 

In the PHP settings in cPanel

What version are you running and what are the timeouts / memory limits set to?

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Sorry, could you tell me how to find the timeout & memory limit info?

 

In PHPmyAdmin I see:

Version information: 4.8.3

@ioet 

That is PHPMyAdmin when you are in cPanel you should be able to type PHP into the "Search" to filter and there should be an option for PHP settings

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

It says:

 

Version 7.3

Memory_limit: 128M

I can't find the timeout time. I've attached photo here so you can see what I see: https://www.dropbox.com/s/7cjmpnw382i9me8/Screen%20Shot%202020-06-01%20at%206.23.15%20PM.png?dl=0

Is there anything I can adjust here?

@ioet 

 

Given the number of images you are trying to upload I would put memory to 256MB and put the max_execution_time to 300 - right now it's at 30 which is seconds

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

Thanks I'll try this and let you know tomorrow if it seems better. I cancelled the upload days ago so I don't understand why it would still be lagging -- unless it's still trying to upload them?

@ioet 

 

Keep in mind that you are on a shared server so it is possible (although not likely) that other customers on the server can affect you

 

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Hi, unfortunately it hasn't worked. I thought it was going faster yesterday after I uploaded a few images but today it seems to be stalling again. When it happens, the whole website goes down and you can't reach it even outside the wordpress panel.

 

Any ideas?

Also, the thing that caused the stall out this time was trying to delete 4 images. It seems deleting them is not working, they come back afterwards.

Another update in the saga.

It seems that when I changed those settings, although at first it seemed images were uploading faster, it would still get stuck eventually, for example when I went to delete an image, sometimes when I choose to enter the media library, etc.

Also, my homepage immediately stopped work. I reverted to previous settings and it works again.

 

I am wondering if there are still many images there that were never properly deleted? They do NOT exist in /uploads but perhaps wp-admin thinks they still exist and that's causing the issue?

@ioet 

 

If you are still trying to upload in a very large batch, it sounds like then you may just be overloading the server - On a "Shared" server you are only allocated so many resources - Until those processes release you won't be able to do anything. If you need more power like that you may want to look at the Managed WordPress hosting, a VPS server or perhaps a cloud server where you can really tweak all of the settings. You are probably looking at a cost of $20-$50/month for the server depending on what type of server you go with, but in order to have the correct amount of resources / performance you need a higher end server.

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

I'm not uploading a large batch at all. I am trying to upload 1 image at a
time. Also, it starts to lag even when I'm not uploading. For example, when
I go into click 'feature image'. Anything to do with the media library.

@ioet 

 

I would go into PHPMyAdmin and optimize your tables - I would also look at your table sizes - this to me sounds a resource issue along with a large database

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Thank you for your advice. Do you have any suggestions for how to do this
exactly?

@ioet 

 

When you are in PHPMyAdmin you can select all the tables in the database - and then select optimize, you can also look at to see the size of each table in the database

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post