cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Highlighted
Helper I

Getting a "PHP Update Required!" on my WP updates page???

I have 3 Go Daddy economy hosted Wordpress sites. (NOT managed hosting).  No problems in over six years.

 

2 of them have the Website Security Essential cheap version.

 

These are parked sites, they are not active blog sites. Someone has to be looking for me to go to them.  I might log in once a month to check for updates and that is it.  One of these is my main website,  this one is slightly bigger and more important than the others is PHP 5.3.

 

I am now getting an update window saying "PHP Update Required".

Two of the sites are PHP 5.3 and one is 5

All are host configuration 2.2

I don't know what any of this means except reading the PHP page said that  updating  it could ruin the website, they can't guarantee it won't, but it shouldn't if your running well known themes etc. (very very confusing reading that statement)

 

I am not technical at all.  I don't really even know how to back up the WP website to my computer or otherwise.

I think Go Daddy can do this for $2.99 a month (for my main website).

 

1) Should I buy that for my main website and then update the PHP?

2) How likely is the PHP update to really ruin my website (There are just photos, text, one embedded video to my Vimeo site, and a few links, on twenty eleven theme)?

3) What if I just left the main website at PHP 5.3?

 

Thanks for any Objective advice here.

Really appreciated.

1 REPLY 1
Super User III Super User III
Super User III
Solution

Re: Getting a "PHP Update Required!" on my WP updates page???

Before upgrading the PHP look up your theme and each plugin that you're using.  Make sure they are all actively being supported and compatible with the latest version of WordPress.  If any are outdated/dormant look for a replacement with the features you need that is still updated.  Even if you're content with the setup you have now it is still recommended to stay up-to-date for security and reduce vulnerability.  Smaller sites can still be targeted and people with malicious intent even have bots that can find 'unlisted' sites.

 

https://wordpress.org/themes/

https://wordpress.org/plugins/