Skip to main content
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
brod40
New

Can I only SSL my woocommerce checkout with a GoDaddy SSL?

Hey, everyone!  I got a GoDaddy SSL when I upgraded my managed wordpress hosting to Ultimate from Deluxe.  Unfortunately I didn't realize what the repercussions would be and I turned it on.  I run a blog and have a lot of backlinks and such and now I've lost all the Pinterest pin stats that were linked to my http site because now I'm https.  

 

So to make a long story short, I realize the benefits of total site SSL (so please don't try to convince me to keep it for total site) but only really want it for my WooCommerce checkout page.  I know there are setting in the WooCommerce install to force https coming in and then force http going out.  But not sure if GoDaddy allows a site to have SSL active but not default site.

 

Anyone had experience with this?

 

thanks

Brad

1 ACCEPTED SOLUTION
oslinux
Helper V

@brod40 I have not used Godaddy's Managed wordpress but SSL setup should be similar for each site.

 

There are several ways to enable SSL on wordpress and to disable SSL it depends on how it was enabled. 

First check for any plugins with SSL or HTTPS in there name. Make sure those plugins are disabled or removed.

Check the Site URL under "Settings" > "General" make sure the URL's start with HTTP:// and not HTTPS:// 

In the example above the WordPress Address (URL) is using SSL and the Site Address (URL) is not using SSL. both should start with http://

As long as you keep the SSL cert installed on your managed wordpress site you should be able to access any link using HTTP:// or HTTPS:// 

 

The last thing to check is your .htaccess file. Make sure you have no redirects to HTTPS.

Look for any lines similar to the code below and delete. 

RewriteCond %{HTTPS} off
# First rewrite to HTTPS:
# Don't put www. here. If it is already there it will be included, if not
# the subsequent rule will catch it.
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
# Now, rewrite any request to the wrong domain to use www.
RewriteCond %{HTTP_HOST} !^www\.
RewriteRule .* https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

 

 

View solution in original post

3 REPLIES 3
CG
Moderator
Moderator

Hey @brod40

 

What it sounds like you're wanting to do is just use our SSL to only secure specific sections of your live site (namely the WooCommerce pages). Should be possible with any of our SSL certificates. It's just a matter of configuring your site to recognize that only your commerce pages be redirected to https while your main blog pages remain on http. 

 

Unfortunately I can't provide you with specific walkthrough information on how to do this. However, I'm positive there's many tutorials available in preferred search engine results that can help in this regard. I would even suggest starting with WooCommerce Docs as they have a section in their codex on SSL usage. 

 

Hopefully some other members familiar with redirecting sections of a site between http vs https can offer some additional insight to this discussion to help out. Keep us posted if you manage to get this worked out on your own as well. 

 

CG - GoDaddy | Community Moderator
24/7 support available at x.co/247support
oslinux
Helper V

@brod40 I have not used Godaddy's Managed wordpress but SSL setup should be similar for each site.

 

There are several ways to enable SSL on wordpress and to disable SSL it depends on how it was enabled. 

First check for any plugins with SSL or HTTPS in there name. Make sure those plugins are disabled or removed.

Check the Site URL under "Settings" > "General" make sure the URL's start with HTTP:// and not HTTPS:// 

In the example above the WordPress Address (URL) is using SSL and the Site Address (URL) is not using SSL. both should start with http://

As long as you keep the SSL cert installed on your managed wordpress site you should be able to access any link using HTTP:// or HTTPS:// 

 

The last thing to check is your .htaccess file. Make sure you have no redirects to HTTPS.

Look for any lines similar to the code below and delete. 

RewriteCond %{HTTPS} off
# First rewrite to HTTPS:
# Don't put www. here. If it is already there it will be included, if not
# the subsequent rule will catch it.
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
# Now, rewrite any request to the wrong domain to use www.
RewriteCond %{HTTP_HOST} !^www\.
RewriteRule .* https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

 

 

View solution in original post

I am not able to edit https to http under General > Settings for wordpress/site URL. Both are greyed out. Any help. 

Thanks