Skip to main content
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
sb14
Getting Started

Forwarding error - http works, https doesn't

Recently, we launched a new website with a new URL. We then forwarded our old URL to the new one. Both URLs are through GoDaddy. We canceled the hosting and SSL certificate with the old website since we no longer need the old site and don't want to keep paying for hosting. We just want to redirect the old URL to the new one. The redirect was completed in GoDaddy using their Forwarding under DNS settings. The forwarding is working properly for http. However, https is providing an error message "Your connection is not private" and also states "NET::ERR_CERT_COMMON_NAME_INVALID". My understanding is this is because the SSL certificate was removed from the old site and Google still has past indexes with https. Google can no longer verify the SSL certificates of course because it was removed. People searching for the old URL and clicking on links that still have the https will get the error message. We don't want to pay for hosting on the old site and add an SSL is get this error message to go away. Is there anything else we can do to get this error message to go away?

2 ACCEPTED SOLUTIONS
Nate
Super User II

@sb14As you've noticed SSL is not available with the included forwarding service.  Though forwarding is activated in the DNS settings it is actually a type of hosting that's specifically for server-side redirects, the free credit is provided with domain registration as a fallback if you do not have other hosting for the situation.  How is the new website hosted?  It may be possible to add the old domain to that account and do the redirect there.

 

 

 

@ProductInsights 

View solution in original post

Nate
Super User II

@sb14  You can add the domain to your Managed WordPress hosting to do the redirect, but you would still need an SSL certificate for https to work.

 

A domain can be added on the same way as changing the domain, just make sure "Make primary" is not checked in step 5.

https://www.godaddy.com/help/change-the-domain-on-my-managed-wordpress-website-16322

View solution in original post

6 REPLIES 6
Nate
Super User II

@sb14As you've noticed SSL is not available with the included forwarding service.  Though forwarding is activated in the DNS settings it is actually a type of hosting that's specifically for server-side redirects, the free credit is provided with domain registration as a fallback if you do not have other hosting for the situation.  How is the new website hosted?  It may be possible to add the old domain to that account and do the redirect there.

 

 

 

@ProductInsights 

View solution in original post

sb14
Getting Started

Thank you for your reply!

The new website is hosted with GoDaddy - the managed Wordpress hosting. 

sb14
Getting Started

Hi @Nate  - I was wondering if you had any additional insights on this issue? Thanks for any help you can provide. 

Nate
Super User II

@sb14  You can add the domain to your Managed WordPress hosting to do the redirect, but you would still need an SSL certificate for https to work.

 

A domain can be added on the same way as changing the domain, just make sure "Make primary" is not checked in step 5.

https://www.godaddy.com/help/change-the-domain-on-my-managed-wordpress-website-16322

View solution in original post

sb14
Getting Started

Thank you, @Nate ! I followed the instructions and attached the old domain to the Managed Wordpress hosting (connected to the new domain). Then I purchased and added an SSL certificate for the old domain, since you said I would still need an SSL certificate for the https to work. I already have an SSL for the new domain. Unfortunately, when I go to the https version of the old domain it still isn't redirecting. I am still getting the "site isn't secure" message. I've cleared my cache and tried multiple browsers. I am not sure what I am doing wrong. I appreciate any insights you can provide. Thank you!! 

sb14
Getting Started

Hi Nate - I thought I would reach out to you again to see if you have any insight as to why this solution isn't working. Thank you!