cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
titusd
Getting Started

Asp.net site "Contact Us" Form not sending email

<?xml version="1.0"?>
<!--
  For more information on how to configure your ASP.NET application, please visit
  http://go.microsoft.com/fwlink/?LinkId=169433
  -->
<configuration>
	<configSections>		
	</configSections>
	<connectionStrings>
		<remove name="LocalSqlServer"/>
	</connectionStrings>
	<appSettings>
		<!-- EMail Setting-->
		<add key="MailHost" value="mailstore1.secureserver.net"/>
		<add key="MailPort" value="25"/>
		<add key="EnableSSL" value="false"/>
		<add key="MailFrom" value="support@shalomtranscription.com"/>
		<add key="MailTo" value="support@shalomtranscription.com"/>
		<add key="MailUser" value="support@shalomtranscription.com"/>
		<add key="MailPassword" value="*********"/>
		<!-- End EMail Setting-->
	</appSettings>
	
	
	
	<system.web>
		<compilation debug="true" targetFramework="4.5.1" defaultLanguage="c#" strict="false" batch="false" optimizeCompilations="true"/>
		<httpRuntime targetFramework="4.5.1"/>
		<pages enableViewState="false" viewStateEncryptionMode="Never">
			<namespaces>
				<add namespace="System.Web.Optimization"/>
				<add namespace="Microsoft.AspNet.FriendlyUrls"/>
			</namespaces>
		</pages>
		<authentication mode="Forms">
			<forms loginUrl="~/Account/Login" timeout="2880" defaultUrl="~/Index.aspx" slidingExpiration="true"/>
		</authentication>
		<trust level="Full"/>
		<customErrors mode="On"/>
	</system.web>
	
	
	
	<!--<runtime>
   
  </runtime>-->
	<system.webServer>
		<defaultDocument>
			<files>
				<add value="Index.aspx"/>
			</files>
		</defaultDocument>
		<rewrite>
			<rules>
				<rule name="Redirect to HTTPS">
					<match url="(.*)"/>
					<conditions>
						<add input="{HTTPS}" pattern="off" ignoreCase="true"/>
					</conditions>
					<action type="Redirect" url="https://{SERVER_NAME}/{R:1}" redirectType="SeeOther"/>
				</rule>
			</rules>
		</rewrite>
		<httpErrors>
		<remove statusCode="400"/><error statusCode="400" path="G:\PleskVhosts\shalomtranscription.com\error_docs\bad_request.html"/>
		<remove statusCode="401"/><error statusCode="401" path="G:\PleskVhosts\shalomtranscription.com\error_docs\unauthorized.html"/>
		<remove statusCode="403"/><error statusCode="403" path="G:\PleskVhosts\shalomtranscription.com\error_docs\forbidden.html"/>
		<remove statusCode="404"/><error statusCode="404" path="G:\PleskVhosts\shalomtranscription.com\error_docs\not_found.html"/>
		<remove statusCode="405"/><error statusCode="405" path="G:\PleskVhosts\shalomtranscription.com\error_docs\method_not_allowed.html"/>
		<remove statusCode="406"/><error statusCode="406" path="G:\PleskVhosts\shalomtranscription.com\error_docs\not_acceptable.html"/>
		<remove statusCode="407"/><error statusCode="407" path="G:\PleskVhosts\shalomtranscription.com\error_docs\proxy_authentication_required.html"/>
		<remove statusCode="412"/><error statusCode="412" path="G:\PleskVhosts\shalomtranscription.com\error_docs\precondition_failed.html"/>
		<remove statusCode="414"/><error statusCode="414" path="G:\PleskVhosts\shalomtranscription.com\error_docs\request-uri_too_long.html"/>
		<remove statusCode="415"/><error statusCode="415" path="G:\PleskVhosts\shalomtranscription.com\error_docs\unsupported_media_type.html"/>
		<remove statusCode="500"/><error statusCode="500" path="G:\PleskVhosts\shalomtranscription.com\error_docs\internal_server_error.html"/>
		<remove statusCode="501"/><error statusCode="501" path="G:\PleskVhosts\shalomtranscription.com\error_docs\not_implemented.html"/>
		<remove statusCode="502"/><error statusCode="502" path="G:\PleskVhosts\shalomtranscription.com\error_docs\bad_gateway.html"/>
		<remove statusCode="503"/><error statusCode="503" path="G:\PleskVhosts\shalomtranscription.com\error_docs\maintenance.html"/>
		</httpErrors>
		</system.webServer>
	<runtime>
		<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
			<dependentAssembly>
				<assemblyIdentity name="System.Web.Optimization" publicKeyToken="31bf3856ad364e35" culture="neutral"/>
				<bindingRedirect oldVersion="0.0.0.0-1.1.0.0" newVersion="1.1.0.0"/>
			</dependentAssembly>
			<dependentAssembly>
				<assemblyIdentity name="WebGrease" publicKeyToken="31bf3856ad364e35" culture="neutral"/>
				<bindingRedirect oldVersion="0.0.0.0-1.5.2.14234" newVersion="1.5.2.14234"/>
			</dependentAssembly>
		</assemblyBinding>
	</runtime>
</configuration>


I have "Contact Us" form on my website to receive email from clients. When submitted showing error message, "Error Occured! Try one more (or) contact us alternate way." I'm using "GoDaddy Professional Email" I'm not sure, if there is some issue in "web.config" file.

Email is working without any issue. We are able to send and receive emails from my clients. When our clients upload files using upload option on our website, I receive the files.

Here is the code on web.config

 

I'm new to this. Any help to resolve this issue is much appreciated.

 

 

1 ACCEPTED SOLUTION
titusd
Getting Started

2 REPLIES 2
titusd
Getting Started

RachelM
Community Manager

Hi @titusd,

Would you please come back and share how this issue was resolved. It really helps other community members who may experience a similar issue in the future. Thanks much!

Rachel

RachelM - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.