Skip to main content
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Using Node 12.0.0

Hello, I'm new to this. I am trying to insall node 12.0.0 because this is the version that can compile mix on my laravel-react project. However, when using 12.0.0, this error appears and node cannot be used.


node: /lib64/libc.so.6: version `GLIBC_2.16' not found (required by node)
node: /lib64/libc.so.6: version `GLIBC_2.17' not found (required by node)
node: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by node)
node: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by node)
node: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.18' not found (required by node)
node: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.19' not found (required by node)
node: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.5' not found (required by node)
node: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by node)
nvm is not compatible with the npm config "prefix" option: currently set to ""
Run `nvm use --delete-prefix v15.10.0 --silent` to unset it.

 

Is there any workaround for this?

1 REPLY 1
JHasselbring
Helper VI

Try going back to version 10.  If it works there, it's likely because your server uses 32bit

~Jan Mykhail Hasselbring Web Administrator @ fullstackwebsolution.com